re = /^(?<Number>[^.]+)\. (?<First>[^-]+) - (?<Second>[^(]+)(?: \((?<Third>[^)]+)\))?$/m
str = '1. Line One - Part Two (Optional Third Part)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end