const regex = /[^\s.](?:[^?.]|\.(?! ))*\?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\s.](?:[^?.]|\\.(?! ))*\\?', 'gm')
const str = `now"? She said, "I feel great". Then I said to her, "All right, would
you mind leaving the room for a minute or two? This is part of the
exercise". So she did. While she was away, I said to the others in the
therapy group, "I am still the provincial superior, O.K.? `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}