# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\s.](?:[^?.]|\.(?! ))*\?"
test_str = ("now\"? She said, \"I feel great\". Then I said to her, \"All right, would \n"
"you mind leaving the room for a minute or two? This is part of the \n"
"exercise\". So she did. While she was away, I said to the others in the \n"
"therapy group, \"I am still the provincial superior, O.K.? ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.