use strict;
my $str = '[default]
host = 10.2.2.15
[monitor://apath]ignoreOlderThan = 14dindex=testsourcetype=whateverignoreOlderThan = 30d
[monitor://truck]
ignoreOlderThan = 14d';
my $regex = qr/(\[monitor[^\]]+\][^\[]?)(ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+?ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}