// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[monitor[^\]]+\][^\[]?)(ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+?ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+)?").unwrap();
let string = "[default]
host = 10.2.2.15
[monitor://apath]ignoreOlderThan = 14dindex=testsourcetype=whateverignoreOlderThan = 30d
[monitor://truck]
ignoreOlderThan = 14d";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}