use strict;
my $str = 'NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu270Gln/c.809T>A|506|nfkbiz|protein_coding|CODING|ENSDART00000172454|6|A|WARNING_TRANSCRIPT_NO_START_CODON),,NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu247Gln/c.740T>A|473|nfkbiz|protein_coding|CODING|ENSDART00000161190|6|A|WARNING_TRANSCRIPT_NO_START_CODON)';
my $regex = qr/NON_SYNONYMOUS_CODING\(([a-zA-Z0-9\.|>_\/]+)\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}