re = /NON_SYNONYMOUS_CODING\(([a-zA-Z0-9\.|>_\/]+)\)/
str = 'NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu270Gln/c.809T>A|506|nfkbiz|protein_coding|CODING|ENSDART00000172454|6|A|WARNING_TRANSCRIPT_NO_START_CODON),,NON_SYNONYMOUS_CODING(MODERATE|MISSENSE|cTg/cAg|p.Leu247Gln/c.740T>A|473|nfkbiz|protein_coding|CODING|ENSDART00000161190|6|A|WARNING_TRANSCRIPT_NO_START_CODON)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end