// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http[s]?:\/\/)05542online.com/uploads/posts/(\d*\-\d*\/\w*\/\d+\w*)([-]?)(\w+\d*).jpg").unwrap();
let string = "https://05542online.com/uploads/posts/2019-01/thumbs/1548168351_49408004_804805043204941_4917756314337148928_n.jpg
https://05542online.com/uploads/posts/2019-01/thumbs/1548166068_49897436_342482663009866_881291499176722432_n.jpg
https://05542online.com/uploads/posts/2019-01/thumbs/1548139537_bufer-obmena01.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}