import Foundation
let pattern = #"(http[s]?:\/\/)05542online.com/uploads/posts/(\d*\-\d*\/\w*\/\d+\w*)([-]?)(\w+\d*).jpg"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://05542online.com/uploads/posts/2019-01/thumbs/1548168351_49408004_804805043204941_4917756314337148928_n.jpg
https://05542online.com/uploads/posts/2019-01/thumbs/1548166068_49897436_342482663009866_881291499176722432_n.jpg
https://05542online.com/uploads/posts/2019-01/thumbs/1548139537_bufer-obmena01.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)