using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)\s\(.+\)\n\sCIK:\s(\d+)\s";
string input = @"ECO Building Products, Inc. (Filed by)
CIK: 0001409885 (see all company filings)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}