re = /^(.+)\s\(.+\)\n\sCIK:\s(\d+)\s/
str = 'ECO Building Products, Inc. (Filed by)
CIK: 0001409885 (see all company filings)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end