import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.*?)\\]";
final String string = "\"The quick, brown fox jumps over a lazy dog. DJs flock by when MTV ax quiz prog. \n"
+ "Junk MTV quiz graced by fox whelps. [Never gonna ] Bawds jog, flick quartz, vex nymphs. \n"
+ "[give you up\\n] Waltz, bad nymph, for quick jigs vex! Fox nymphs grab quick-jived waltz. \n"
+ "Brick quiz whangs jumpy veldt fox. [Never ] Bright vixens jump; [gonna let ] dozy fowl \n"
+ "quack. Quick wafting zephyrs vex bold Jim. Quick zephyrs blow, vexing daft Jim. Charged \n"
+ "[you down\\n] fop blew my junk TV quiz. How quickly daft jumping zebras vex. Two driven \n"
+ "jocks help fax my big quiz. Quick, Baz, get my woven flax jodhpurs! \"Now fax quiz Jack!\" \n"
+ "my brave ghost pled. [Never ] Five quacking zephyrs jolt my wax bed. [gonna ] Flummoxed \n"
+ "by job, kvetching W. zaps Iraq. Cozy sphinx waves quart jug of bad milk. [run around ] \n"
+ "A very bad quack might jinx zippy fowls. Few quips galvanized the mock jury box. Quick \n"
+ "brown dogs jump over the lazy fox. The jay, pig, fox, zebra, and my wolves quack! \n"
+ "[and desert you] Blowzy red vixens fight for a quick jump. Joaquin Phoenix was gazed \n"
+ "by MTV for luck. A wizard’s job is to vex chumps quickly in fog. Watch \"Jeopardy!\", \n"
+ "Alex Trebek's fun TV quiz game.\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}