$re = '/(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d]{8,}/um';
$str = 'sssssss8
Mlmlml903
Mlmlml
Mssssss8
df12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);