re = /(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d]{8,}/m
str = 'sssssss8
Mlmlml903
Mlmlml
Mssssss8
df12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end