package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*/)?([^/\n?]+)`)
var str = `https://www.example.com/post/abc-def/
https://www.example.com/post/abc-def
https://www.example.com/post/abc-def?p=294
https://www.example.com/post/abc-def/?p=294
http://www.example.com/abc-def/?p=294`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}