$re = '`^(?:.*/)?([^/\n?]+)`m';
$str = 'https://www.example.com/post/abc-def/
https://www.example.com/post/abc-def
https://www.example.com/post/abc-def?p=294
https://www.example.com/post/abc-def/?p=294
http://www.example.com/abc-def/?p=294';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);