re = /(?<=\bconnectionString=")[^"]*/m
str = '<connectionStrings>
<add name="FrameworkEntities" connectionString="metadata=res://*/PortalEntities.csdl|res://*/PortalEntities.ssdl|res://*/PortalEntities.msl;provider=System.Data.SqlClient;
provider connection string="data source=someservername.domain.co;initial catalog=Portal;persist security info=True;user
id=user;password=user$ecurity;MultipleActiveResultSets=True;App=EntityFramework;" providerName="System.Data.EntityClient" />
</connectionStrings>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end