#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Material:\s*(.+)"
Local $sString = "Color: Maroon Red" & @CRLF & _
"Height: 187cm" & @CRLF & _
"Number Of Seats: 6" & @CRLF & _
"Number Of Wheels: 4" & @CRLF & _
"Material: Aluminum" & @CRLF & _
"Brand: Toyota " & @CRLF & _
"#and hundreds of more lines..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")