re = /^Material:\s*(.+)/m
str = 'Color: Maroon Red
Height: 187cm
Number Of Seats: 6
Number Of Wheels: 4
Material: Aluminum
Brand: Toyota
#and hundreds of more lines...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end