#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<((?!a|\/a)[^>]*)>\s*"
Local $sString = "<html>" & @CRLF & _
"<head>" & @CRLF & _
"<meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\">" & @CRLF & _
"<meta content=\"text/html; charset=us-ascii\">" & @CRLF & _
"<meta name=\"ProgId\" content=\"Word.Document\">" & @CRLF & _
"<meta name=\"Generator\" content=\"Microsoft Word 15\">" & @CRLF & _
"<meta name=\"Originator\" content=\"Microsoft Word 15\">" & @CRLF & _
"<style>" & @CRLF & _
"<!--" & @CRLF & _
"@font-face" & @CRLF & _
"\t{font-family:\"Cambria Math\"}" & @CRLF & _
"@font-face" & @CRLF & _
"\t{font-family:Calibri}" & @CRLF & _
"p.MsoNormal, li.MsoNormal, div.MsoNormal" & @CRLF & _
"\t{margin:0cm;" & @CRLF & _
"\tmargin-bottom:.0001pt;" & @CRLF & _
"\tfont-size:11.0pt;" & @CRLF & _
"\tfont-family:\"Calibri\",sans-serif}" & @CRLF & _
"a:link, span.MsoHyperlink" & @CRLF & _
"\t{color:#0563C1;" & @CRLF & _
"\ttext-decoration:underline}" & @CRLF & _
"a:visited, span.MsoHyperlinkFollowed" & @CRLF & _
"\t{color:#954F72;" & @CRLF & _
"\ttext-decoration:underline}" & @CRLF & _
"p.msonormal0, li.msonormal0, div.msonormal0" & @CRLF & _
"\t{margin-right:0cm;" & @CRLF & _
"\tmargin-left:0cm;" & @CRLF & _
"\tfont-size:11.0pt;" & @CRLF & _
"\tfont-family:\"Calibri\",sans-serif}" & @CRLF & _
"span.EmailStyle18" & @CRLF & _
"\t{font-family:\"Calibri\",sans-serif}" & @CRLF & _
".MsoChpDefault" & @CRLF & _
"\t{font-size:10.0pt;" & @CRLF & _
"\tfont-family:\"Calibri\",sans-serif}" & @CRLF & _
"@page WordSection1" & @CRLF & _
"\t{margin:72.0pt 72.0pt 72.0pt 72.0pt}" & @CRLF & _
"div.WordSection1" & @CRLF & _
"\t{}" & @CRLF & _
"-->" & @CRLF & _
"</style>" & @CRLF & _
"</head>" & @CRLF & _
"<body lang=\"EN-GB\" link=\"#0563C1\" vlink=\"#954F72\" style=\"\">" & @CRLF & _
"<div class=\"WordSection1\">" & @CRLF & _
"<p class=\"MsoNormal\">I NEED TO HAVE THIS STRING</p>" & @CRLF & _
"<p class=\"MsoNormal\"> </p>" & @CRLF & _
"<p class=\"MsoNormal\"><span style=\"\">AND I NEED THE FOLLOWING ANCHOR" & @CRLF & _
"<a href=\"google.com\">" & @CRLF & _
" THIS ONE</a>.</span></p>" & @CRLF & _
"<p class=\"MsoNormal\"> </p>" & @CRLF & _
"</div>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)