using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<((?!a|\/a)[^>]*)>\s*";
string substitution = @"";
string input = @"<html>
<head>
<meta http-equiv=\""Content-Type\"" content=\""text/html; charset=utf-8\"">
<meta content=\""text/html; charset=us-ascii\"">
<meta name=\""ProgId\"" content=\""Word.Document\"">
<meta name=\""Generator\"" content=\""Microsoft Word 15\"">
<meta name=\""Originator\"" content=\""Microsoft Word 15\"">
<style>
<!--
@font-face
\t{font-family:\""Cambria Math\""}
@font-face
\t{font-family:Calibri}
p.MsoNormal, li.MsoNormal, div.MsoNormal
\t{margin:0cm;
\tmargin-bottom:.0001pt;
\tfont-size:11.0pt;
\tfont-family:\""Calibri\"",sans-serif}
a:link, span.MsoHyperlink
\t{color:#0563C1;
\ttext-decoration:underline}
a:visited, span.MsoHyperlinkFollowed
\t{color:#954F72;
\ttext-decoration:underline}
p.msonormal0, li.msonormal0, div.msonormal0
\t{margin-right:0cm;
\tmargin-left:0cm;
\tfont-size:11.0pt;
\tfont-family:\""Calibri\"",sans-serif}
span.EmailStyle18
\t{font-family:\""Calibri\"",sans-serif}
.MsoChpDefault
\t{font-size:10.0pt;
\tfont-family:\""Calibri\"",sans-serif}
@page WordSection1
\t{margin:72.0pt 72.0pt 72.0pt 72.0pt}
div.WordSection1
\t{}
-->
</style>
</head>
<body lang=\""EN-GB\"" link=\""#0563C1\"" vlink=\""#954F72\"" style=\""\"">
<div class=\""WordSection1\"">
<p class=\""MsoNormal\"">I NEED TO HAVE THIS STRING</p>
<p class=\""MsoNormal\""> </p>
<p class=\""MsoNormal\""><span style=\""\"">AND I NEED THE FOLLOWING ANCHOR
<a href=\""google.com\"">
THIS ONE</a>.</span></p>
<p class=\""MsoNormal\""> </p>
</div>
</body>
</html>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}