package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,3}(?:,\d{3})*)$`)
var str = `42
1,234
6,368,745
12,34,567
9999999,123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}