re = /^(?:\d{1,3}(?:,\d{3})*)$/m
str = '42
1,234
6,368,745
12,34,567
9999999,123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end