$re = '/[^ =]+=[^= ]+(?:(?! [^\s=]+=) [^= ]+)*/m';
$str = 'key1=value1 key2=value2 key3=multiple values';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);