re = /[^ =]+=[^= ]+(?:(?! [^\s=]+=) [^= ]+)*/m
str = 'key1=value1 key2=value2 key3=multiple values'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end