#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(([(|\[](?P<series>[^)\]]*)[)|\]]))?((?P<author>.*[^\s][^\-])[\s]+-[\s]*)?(?P<title>[^(]*)([(|\[](?:[\s]*(?P<published>(([12][\d]{3,3})(?:(?!([^.\)\-a-zA-Z_]*(-+[^.\)a-zA-Z_]+)+)))))?)?[\s]*([,]?[\s]*(?P<publisher>[\s\w\s]*)[\s]*)?([,]?[\s]*(isbn:|isbn[-]?13:)?(?P<isbn>[0-9-]+))?[)|\]])?"
Local $sString = "(1958, Open Road d34234234, 978-1-4532-1730-6).epub" & @CRLF & _
"(1958, Open Ro234ad , 9781-4532-o1730-6).epub" & @CRLF & _
"(1958, Open Rosd234ad ).epub" & @CRLF & _
"( 1958 ).epub" & @CRLF & _
"(1958).epub" & @CRLF & _
"( Open Road ).epub" & @CRLF & _
"(Open road , 9234-1-4532-17300-9-6).epub" & @CRLF & _
"(1234, 9234-1-4532-17300-9-6).epub" & @CRLF & _
"(91886).epub" & @CRLF & _
"(9186).epub" & @CRLF & _
"(1186).epub" & @CRLF & _
"" & @CRLF & _
"title (1958, Open Road34234234, 978-1-4532-1730-6).epub" & @CRLF & _
"(asdf) author, a2 - title ioiuoi-uyoiu (1958, Open Ro234ad , 9781-4532-1730-6).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu (1958, Open Rosd234ad ).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu ( 1958 ).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu (1958).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu ( Open Road ).epub" & @CRLF & _
"(dddfasdfasdf) author666, a66df - title ioiuoi-uyoiu (Open road , 9234-1-4532-17300-9-6).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu (1234, 9234-1-4532-17300-9-6).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu (1234, 923416).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu ( 91886-8).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu ( 9186 ).epub" & @CRLF & _
"author, adf - title ioiuoi-uyoiu ( 1186 ).epub" & @CRLF & _
"(dddfasdfasdf) author666, a66df - title ioiuoi-uyoiu ( Open road , isbn:9234-1-4532-17300-9-6).epub" & @CRLF & _
"(dddfasdfasdf) author666, a66df - title ioiuoi-uyoiu ( Open road , isbn13:9234-1-4532-17300-9-6).epub" & @CRLF & _
"(dddfasdfasdf) author666, a66df - title ioiuoi-uyoiu ( Open road , isbn-13:9234-1-4532-17300-9-6).epub" & @CRLF & _
"(dddfasdfasdf) author666, a66df - title ioiuoi-uyoiu ( Open road , 9234-1-4532-17300-9-6).epub"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")