#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)log\.info\((?:(?!DEBUG|\);)[\w\W])*\);"
Local $sString = "log.info(" & @CRLF & _
" `DEBUG other strings..." & @CRLF & _
");" & @CRLF & _
"with nothing (I want to delete them in all files); for example, this log.info should be removed:" & @CRLF & _
"" & @CRLF & _
"log.info(" & @CRLF & _
" `remove this instruction!!!" & @CRLF & _
");" & @CRLF & _
"but not this (it has DEBUG has first word):" & @CRLF & _
"" & @CRLF & _
"log.info(" & @CRLF & _
" `DEBUG other strings..." & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")