$re = '/log\.info\((?:(?!DEBUG|\);)[\w\W])*\);/m';
$str = 'log.info(
`DEBUG other strings...
);
with nothing (I want to delete them in all files); for example, this log.info should be removed:
log.info(
`remove this instruction!!!
);
but not this (it has DEBUG has first word):
log.info(
`DEBUG other strings...
);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);