using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(input)(?:\s+type=([\'""]?)(?<type>[^\'""]*?)\2\s*)?(?:\s+name=([\'""]?)(?<name>[^\'""]*?)\4\s*)?(?:\s+value=([\'""]?)(?<value>[^\'""]*?)\6\s*)?>";
string input = @"<input type='hidden' name='student' value='9208'>
<input type='hidden' name=""student"" value='9208'>
<input type='hidden' name='student' value=9208>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}