import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(input)(?:\\s+type=([\\'\"]?)(?<type>[^\\'\"]*?)\\2\\s*)?(?:\\s+name=([\\'\"]?)(?<name>[^\\'\"]*?)\\4\\s*)?(?:\\s+value=([\\'\"]?)(?<value>[^\\'\"]*?)\\6\\s*)?>";
final String string = "<input type='hidden' name='student' value='9208'>\n"
+ "<input type='hidden' name=\"student\" value='9208'>\n"
+ "<input type='hidden' name='student' value=9208>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}