$re = '/[0-9]*\.[0-9]*\.[0-9]*\.[0-9]*/m';
$str = '300.300.300.300
1234567890.1.1.1
192..1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);