re = /[0-9]*\.[0-9]*\.[0-9]*\.[0-9]*/m
str = '300.300.300.300
1234567890.1.1.1
192..1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end