const regex = new RegExp('(\\\\Pending\\\\(?:(?!\\bPending\\b).)*\\\\)(?=[^\\\\]*m2et)', 'g')
const str = `hfhfdgdx:\\sdfsdfs\\Pending\\1\\sfsdf\\sdfsd\\eewrwe.movRTrdgdgdgdfx:\\sdfsdfs\\Pending\\2\\sfsdf\\sdfsd\\eewrwe.3gpGFDSDSx:\\sdfsdfs\\Pending\\3\\sfsdf\\sdfsd\\eewrwe.m2etdfgdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}