$re = '/(\\\\Pending\\\\(?:(?!\bPending\b).)*\\\\)(?=[^\\\\]*m2et)/';
$str = 'hfhfdgdx:\\sdfsdfs\\Pending\\1\\sfsdf\\sdfsd\\eewrwe.movRTrdgdgdgdfx:\\sdfsdfs\\Pending\\2\\sfsdf\\sdfsd\\eewrwe.3gpGFDSDSx:\\sdfsdfs\\Pending\\3\\sfsdf\\sdfsd\\eewrwe.m2etdfgdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);