const regex = new RegExp('.*([0-9])([0-9]{2}).*', 'gm')
const str = `machine240dev`;
const subst = `\1.\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);