import Foundation
let pattern = #".*([0-9])([0-9]{2}).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"machine240dev"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)