re = /^(?!.*\.(?:test|spec|es[56])\.(?:(?:bundle\.)?js$)).*\.(?:bundle\.)?js$/im
str = 'bunle.spec.js
my.main.js
test.es6.js
te.es5.js
file.test.js
abc.js
ee.ff.abc.js
eeee.ffff.abc.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end