const regex = /^\S*(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=\S*[\W])[a-zA-Z\d]{8,}\S*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\S*(?=.*[a-z])(?=.*[A-Z])(?=.*\\d)(?=\\S*[\\W])[a-zA-Z\\d]{8,}\\S*$', '')
const str = `abcAAA12@@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}