re = /^\S*(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=\S*[\W])[a-zA-Z\d]{8,}\S*$/
str = 'abcAAA12@@'
# Print the match result
str.match(re) do |match|
puts match.to_s
end