re = /\b\d+(?:\.\d)?\w*(?:-\w+)*/m
str = 'Examplestreet 1/2.1/3a/10/10.1/11b/12a-12c/13a-c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end