// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\d+(?:\.\d)?\w*(?:-\w+)*").unwrap();
let string = "Examplestreet 1/2.1/3a/10/10.1/11b/12a-12c/13a-c";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}