import re
regex = re.compile(r".*\.(\w{1,})$|(.*)", flags=re.MULTILINE)
test_str = ("/lib/kbd/console.trans/spacetoto \n"
"/lib/kbd/console.trans/spacetoto.txt\n"
"/lib/kbd/consoletrans/spacetoto\n"
"/lib/kbd/console.trans/space+toto\n"
"/integration/jenkins-IC-SLV4/workspace/RMIX_IMIR/trunk/.svn/entries")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)