package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d+(,\d+)?(\.\d+)?$`)
var str = `111
+111
-111
1.11
+1.11
-1.11
1,111
+1,111
-1,111
1,111.01
+1,111.01
-1,111.01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}