re = /^[+-]?\d+(,\d+)?(\.\d+)?$/m
str = '111
+111
-111
1.11
+1.11
-1.11
1,111
+1,111
-1,111
1,111.01
+1,111.01
-1,111.01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end