# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<([^ ]*)[^=]*?={([^}]*?)}>([^<]*)<\\/\1>\s*/<!-- $2 -->$3/g;t' <<< "<section className={CLASS_A}>
Un-touched stuff here
</section>
<hr />
<section className={CLASS_B}>
Un-touched stuff here
</section>"