const regex = /<([^ ]*)[^=]*?={([^}]*?)}>([^<]*)<\/\1>\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^ ]*)[^=]*?={([^}]*?)}>([^<]*)<\\\/\\1>\\s*', 'g')
const str = `<section className={CLASS_A}>
Un-touched stuff here
</section>
<hr />
<section className={CLASS_B}>
Un-touched stuff here
</section>`;
const subst = `<!-- $2 -->$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);