package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^\|]*\|){3}.(.{2})`)
var str = `|guhk|h657|hiik|hhh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}