$re = '/^(?:[^\|]*\|){3}.(.{2})/';
$str = '|guhk|h657|hiik|hhh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);