#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)# Time:\s(?<timestamp>.*)\n#.*Id:\s(?<id>.*)\n#\sQuery_time:\s(?<duration>[\d.]*)\s.*time:\s(?<lock_time>[\d.]*)\s.*_sent:\s(?<returned>\d*)\s.*_examined:\s(?<searched>\d*)\n(?<sql>[\s\S]*)"
Local $sString = " " & @CRLF & _
"# Time: 210607 16:27:16" & @CRLF & _
"# User@Host: doctime_db_usr[doctime_db_usr] @ [10.2.0.79] Id: 13021" & @CRLF & _
"# Query_time: 20.504504 Lock_time: 0.000233 Rows_sent: 52 Rows_examined: 13827347" & @CRLF & _
"SET timestamp=1623083236;" & @CRLF & _
"SELECT" & @CRLF & _
"substring( substring_index( uri, '/', -1 ) , 1, LENGTH(substring_index( uri, '/', -1 )) - 38 ) AS uri," & @CRLF & _
"namespace," & @CRLF & _
"method," & @CRLF & _
"count(*) AS hits" & @CRLF & _
"FROM" & @CRLF & _
"user_hits" & @CRLF & _
"WHERE" & @CRLF & _
"namespace = 'hospitals' AND" & @CRLF & _
"controller = 'queue' AND" & @CRLF & _
"method = 'file'" & @CRLF & _
"GROUP BY" & @CRLF & _
"substring( substring_index( uri, '/', -1 ) , 1, LENGTH(substring_index( uri, '/', -1 )) - 38 )" & @CRLF & _
"UNION" & @CRLF & _
"SELECT" & @CRLF & _
"uri," & @CRLF & _
"namespace," & @CRLF & _
"method," & @CRLF & _
"count(*) AS hits" & @CRLF & _
"FROM" & @CRLF & _
"user_hits" & @CRLF & _
"WHERE" & @CRLF & _
"uri LIKE '%export%'" & @CRLF & _
"GROUP BY" & @CRLF & _
"method" & @CRLF & _
"ORDER BY hits DESC;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")