re = /# Time:\s(?<timestamp>.*)\n#.*Id:\s(?<id>.*)\n#\sQuery_time:\s(?<duration>[\d.]*)\s.*time:\s(?<lock_time>[\d.]*)\s.*_sent:\s(?<returned>\d*)\s.*_examined:\s(?<searched>\d*)\n(?<sql>[\s\S]*)/m
str = '
# Time: 210607 16:27:16
# User@Host: doctime_db_usr[doctime_db_usr] @ [10.2.0.79] Id: 13021
# Query_time: 20.504504 Lock_time: 0.000233 Rows_sent: 52 Rows_examined: 13827347
SET timestamp=1623083236;
SELECT
substring( substring_index( uri, \'/\', -1 ) , 1, LENGTH(substring_index( uri, \'/\', -1 )) - 38 ) AS uri,
namespace,
method,
count(*) AS hits
FROM
user_hits
WHERE
namespace = \'hospitals\' AND
controller = \'queue\' AND
method = \'file\'
GROUP BY
substring( substring_index( uri, \'/\', -1 ) , 1, LENGTH(substring_index( uri, \'/\', -1 )) - 38 )
UNION
SELECT
uri,
namespace,
method,
count(*) AS hits
FROM
user_hits
WHERE
uri LIKE \'%export%\'
GROUP BY
method
ORDER BY hits DESC;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end